' связка install' не работа в рельсах

Я создал новый проект рельсов рельсы новое приложение . Тогда командная строка показала создание нескольких файлов и затем показана связку пробега, устанавливают и показал некоторый материал после этого.

Однако тогда я изменил Gemfile, чтобы добавить некоторые новые драгоценные камни и бежал связку, устанавливают снова, чтобы установить те драгоценные камни, но я добираюсь недействительный аргумент ошибка. Так, как я бегу, связка устанавливают?

Версия рельсов: 3.2.1, Рубиновая версия: 1.9.3

Вот Gemfile

source 'https://rubygems.org'

gem 'rails', '3.2.1'

# Bundle edge Rails instead:
# gem 'rails', :git => 'git://github.com/rails/rails.git'

gem 'sqlite3'


# Gems used only for assets and not required
# in production environments by default.
group :assets do
  gem 'sass-rails',   '~> 3.2.3'
  gem 'coffee-rails', '~> 3.2.1'

  # See https://github.com/sstephenson/execjs#readme for more supported runtimes
  # gem 'therubyracer'

  gem 'uglifier', '>= 1.0.3'
end

group :development do
  gem 'rspec-rails', '2.0.0.beta.18'
end

group :test do
    gem 'rspec', '2.0.0.beta.18'
end

gem 'jquery-rails'

Update

Как, оказывается, что я установил что-то названное MoSync некоторое время назад, и это, вероятно, шло с командой связки с ним. Так, когда я печатал связку, устанавливают , это пыталось бежать, почти не мог найти действительный аргумент.

Стало ясно, когда я напечатал, просто связку в powershell и видел это:

MAUtil::MAFS Bundle tool

This tool is used to build a binary image of a folder on a desktop computer.

Usage:
bundle 

Parameters:
  -in <input file or folder> the input files or folders to add to the
                             image (multiple -in directives may be added).
  -out          the name of the image to be created (only one).
  -toUpper/-toLower          change case of all file names to upper or lower
                             case.

Example:
  bundle -in data -out anotherworld.bun -toLower
0
добавлено отредактировано
Просмотры: 2
nl ja de
@Agis ошибка просто так очень только. Два слова, который является.
добавлено автор Jatin, источник
@Kulgar, По-видимому, проблемой было что-то совершенно различное, поскольку я обновил детали вопроса.
добавлено автор Jatin, источник
@Kulgar Спасибо! Ценят вас помощь! Обновит, если я получу решение.
добавлено автор Jatin, источник
@Kulgar я нахожусь на окнах. Ну, я мог бы дать ему движение, если я сталкиваюсь с большим количеством проблем.
добавлено автор Jatin, источник
@Kulgar кроме того, даже если я управляю связкой, устанавливают, не изменяя Gemfile, она все еще дает ту же самую ошибку.
добавлено автор Jatin, источник
@Kulgar, Когда я говорю, что добавил новые драгоценные камни, я подразумевал, что добавил их имена в Gemfile. Тогда я бежал связку, устанавливают . Я должен сделать что-то еще?
добавлено автор Jatin, источник
Шоу связки @Agis дает ту же самую ошибку недействительный аргумент
добавлено автор Jatin, источник
@Agis я использовал инсталлятор рельсов (railsinstaller.org). Это установило bundler для меня. И ошибка появляется даже после удаления опечатки.
добавлено автор Jatin, источник
Есть опечатка в rspec-рельсы последовательность вариантов: ' bete' вместо ' beta'. I' m не уверенный, если это - проблема, но можно попробовать:).
добавлено автор mrzasa, источник
@Jatin вы попробовали шоу связки ? Что это производит?
добавлено автор Agis, источник
@Jatin Никакие ошибки линии? Странный.. Попробуйте шоу связки . Как вы устанавливали Bundler? Также there' s ошибка в вашем rspec драгоценном камне ( bete должен быть бету ).
добавлено автор Agis, источник
Покажите нам свой Gemfile, наиболее вероятный there' s ошибка в нем. Также покажите нам фактический вывод ошибок. You' ре, не дающее нам достаточно информации, чтобы помочь вам и нам can' t предположение:)
добавлено автор Agis, источник
Вы говорите, что добавляете некоторые новые драгоценные камни, какие драгоценные камни вы добавляли? Вы пытались удалить их, и связка launche устанавливают снова? Это поднимало ту же самую ошибку? Если не можно добавить драгоценные камни один за другим и найти один that' s подъем ошибки.
добавлено автор Kulgar, источник
@Jatin: таким образом мы можем предположить что ошибка doesn' t прибывают из вашего Gemfile. What' s ваш OS? Windows? Если так, у меня было бы скорее использование: rubyinstaller.org взятие последней версии рубина и DevKit, затем установка bundler как драгоценный камень тогда Рельсы как драгоценный камень.:) RailsInstaller doesn' у t есть актуальная версия Руби, и bundler - версия 1.2 в наше время... Не уверенный, если это решит что-нибудь кроме вас, может попытаться, это может быть проблема совместимости между рубином и драгоценными камнями.
добавлено автор Kulgar, источник
К сожалению, вы won' t идут далеко если вы can' t решают эту ошибку связки:-(... Драгоценные камни - сердце Рельсов... Возможно, я должен попытаться установить инсталлятор рельсов и видеть, есть ли у меня та же самая проблема? ^^'
добавлено автор Kulgar, источник
Хорошо, I' ve установил рубин и рельсы, используя railsinstaller... Я создал новый проект, измените мой Gemfile с вашим, и сделал связку, устанавливают, и он работал отлично... Так, ваша ошибка определенно происходит из вашей среды и меня can' t видят способ воспроизвести вашу ошибку...:-(Вы могли попытаться отправить проблему о railsinstaller группе Google: groups.google.com/forum/? fromgroups#! forum/railsinstaller Они должны иметь более опытный, чем какой-либо stackoverflow читатель об их собственном инструменте и проблемах совместимости окружающей среды... Don' t забывают редактировать ваш вопрос, если они помогают вам исправить свою ошибку.
добавлено автор Kulgar, источник
That' s большой! It' ll, конечно, помогают другим, если у них есть та же самая ошибка с командой связки.;)
добавлено автор Kulgar, источник

3 ответы

Вы должны будете любому создать псевдоним, используя doskey :

doskey bundull=C:\ruby\bin\bundle
bundull install

Или управляйте им с полным путем:

C:\ruby\bin\bundle install

Примечание, что C:\ruby\ должен быть изменен на путь, на котором вы установили Инсталлятор Рельсов.

You can also adjust your path and make C:\ruby\ the most important by going to "Control Panel > System > Environment Variables (button at the bottom)" and then editing Path and moving the path to Rails Installer up higher (before anything else.) Doing this method will prevent errors with Rails in the future but occasionally you will have to adjust your path because other things can adjust your path while installing.

2
добавлено

Кажется, что вы управляете Windows OS. Возможно, это мог бы быть скрытый символ где-нибудь? Самая легкая вещь сделать состоит в том, чтобы установить что-то как RVM (Рубиновый менеджер по Версии). Я полагаю, что это - Pik для Windows (https://github.com/vertiginous/pik/). Попытайтесь установить снова.

Также попытайтесь удалить все после 'беты' в

2.0.0.beta.18

сделать его

драгоценный камень 'rspec-рельсы ', 2.0.0.beta'

0
добавлено
MAUtil::MAFS Bundle tool

This tool is used to build a binary image of a folder on a desktop computer.

Usage:
bundle 

Parameters:
  -in <input file or folder> the input files or folders to add to the
                             image (multiple -in directives may be added).
  -out          the name of the image to be created (only one).
  -toUpper/-toLower          change case of all file names to upper or lower
                             case.

Example:
  bundle -in data -out anotherworld.bun -toLower

That bundle command executed from Mosync. Check this link. http://www.mosync.com/docs/sdk/cpp/guides/storage/mafs-library/index.html

[РЕШЕНИЕ 1] Удалите Mosync из СИСТЕМНОГО ПУТИ, тогда пытаются использовать связку снова.

[РЕШЕНИЕ 2] Прямой доступ для связки для рубина

C:\Ruby193\bin\bundle install
0
добавлено
pro.ruby
pro.ruby
1 181 участник(ов)

Язык программирования Ruby Additional docs: https://rubyreferences.github.io/rubyref/ Invite: https://telegram.me/joinchat/Be4rsT2NuB3CyJaF26j1kA Кто хочет компилировать: @crystal_ru (его синтаксис основан на Ruby) Участник @proDOT

Ruby, Rails, Hanami | dry-rb
Ruby, Rails, Hanami | dry-rb
1 180 участник(ов)

https://telegram.me/rubyjob - Ruby Job По вопросам - @eugene_shved

Ruby School .us
Ruby School .us
1 045 участник(ов)

Чат-болталка для учеников руби-школы и не только. Правила: https://telegra.ph/Pravila-chata-Rubi-shkoly-03-13

Random Ruby Chat
Random Ruby Chat
589 участник(ов)

Правила публикации вакансий: https://t.me/codenamecrud/60865

Rubyata
Rubyata
333 участник(ов)

Коммюнити Ruby и Ruby On Rails Флуд не приветствуются. Вакансии можно публиковать только и ТОЛЬКО по пятницам с хештегом #вакансия.

Ruby Talks
Ruby Talks
236 участник(ов)

Национальная Флеймотека

RubyRush
RubyRush
189 участник(ов)

rubyrush.ru программирование для самых новичков

Rails Chat
Rails Chat
87 участник(ов)

You are welcome to discuss Ruby On Rails development process and other stuff