То, кто такие самые низкие разработчики iOS вариантов, может создать приложение для?

Все еще возможно создать приложение для iOS 4.2.1 (или ниже)???

The reason for this question is that Whatsapp is not available anymore for iOS < 4.3. This is what Whatsapp sais about this:

Последняя версия WhatsApp для iPhone требует iOS 4.3 или позже. К сожалению Apple не позволяет новым обновлениям приложения быть совместимыми и с iOS 6 и с более старыми версиями iOS, эффективно заканчивая поддержку iPhone 3G и оригинального iPhone. Из-за изменения политики Apple к новым отправкам приложения в магазин нет ничего, что мы можем сделать в это время для пользователей с более старыми версиями iOS.

0
nl ja de
То, что WhatsApp говорят, правильно, хотя там способы включать поддержку ARMv6 и там iOS 4.* и даже 3.* к вашему приложению. Но это действительно включает многократные наборы из двух предметов в наборы из двух предметов (толстый набор из двух предметов).
добавлено автор rckoenes, источник
Если вы хотите поддержать свое приложение для iOS 6 тогда, вы не можете поддержать версию iOS меньше чем 4.2, потому что у Xcode 4.5 нет поддержки меньшей версии, чем iOS 4.2.
добавлено автор Sumanth, источник
Технически самая низкая версия для официального развития равняется 2, хотя наборы инструментальных средств существуют (редактор) для неофициального развития, так как оригинальный iPhone вышел. "It' s не возможный написать приложения iOS 4.2 дюйма просто Apple' s БАКАЛАВР НАУК и глупое ограничение в заказе все, чтобы купить последнее устройство (и сделать разлачивание тяжелее).
добавлено автор user529758, источник

3 ответы

С версией 4.5.x XCode или позже, вы не можете создать приложение для устройств, имеющих iOS 4.3.

Однако, iPhone запускается с iOS 2. Таким образом с более низкими версиями XCode и iOS SDK, можно создать приложения для тех версий также. Но его важное, когда вы хотите поддержать iPhone5 с большим экраном.

С более низкими версиями iOS SDK можно создать приложение, которое может поддержать устройства, имеющие iOS 4.* вперед. Но с теми заявлениями, вы не можете использовать в своих интересах большой экран iPhone5.

3
добавлено
I' m уверенный, что это возможный создать приложения, которые поддерживают iOS 6 и все более ранние, но it' s не простой и it' s не действительно практичный...
добавлено автор Stephen Darlington, источник

Согласно вставке, только исключены обновления . Что означает, что все еще возможно создать приложения для iOS 4.2.1 или ниже. Я просто представил приложение приблизительно две недели назад, которое было создано, используя XCode 4.5.1 и использует sdk ниже, чем 4.2.1 беспрепятственных.

1
добавлено

(Более полное вопрос и ответы)

Таблица поддержки v2.4 iOS

Эта версия обновляется и включает iOS 7.

iOS Suport Matrix

Link: http://www.iossupportmatrix.com

0
добавлено
Mobile Dev Jobs — вакансии и аналитика
Mobile Dev Jobs — вакансии и аналитика
6 187 участник(ов)

Публикуем вакансии и запросы на поиск работы по направлению iOS, Android, Xamarin и т.д. ВАЖНО: Правила публикации и правила канала: Ссылка – https://telegra.ph/Pravila-oformleniya-vakansij-i-rezyume-11-09-2

iOS Developers — русскоговорящее сообщество
iOS Developers — русскоговорящее сообщество
2 400 участник(ов)

Общаемся на темы, посвященным iOS-разработке, Swift, Objective-C, SDK, Rx, Cocoa и т.д.