Приложение перестало работать на устройстве - «Нет такого файла или каталога»

Сначала я начал создавать приложение для iPhone (приложение, все еще находящееся на стадии разработки) с помощью Xcode 4.2 , он отлично работал как на устройстве, так и на симуляторе. Позднее мы хотели добавить поддержку для iPhone 5 (4-дюймовый дисплей). Когда я запускал его на Xcode 4.5 (включая Default-568h.png), он работал нормально (на симуляторе - 3,5 дюйма и 4 дюйма). Но когда я попытался запустить его на устройстве, он продолжает давать мне ошибку

"Could not launch appname.app” No such file or directory (/Users//Library/Developer/Xcode/DerivedData/appname-ffotpypmbvaguyhfvnnejhjotpbp/Build/Products/Debug-iphoneos/appname.app/appname).

Я пробовал следующие шаги, но не повезло: (

  • Удалено приложение с устройства. Перезагрузите устройство.
  • Закройте XCode. Выделите все папки из `DerivedData.Cleaned проекта. Restarted машина.
  • Установите Build для активной архитектуры в YES
  • Удаленный Обязательные возможности устройства from -info.plist

Есть ли у меня какие-либо другие варианты, или я должен повторять их снова и снова?

0
nl ja de
У меня тоже было это. Разочарование. Вы также исправили все предупреждения?
добавлено автор No Grabbing, источник
@skinnyTOD Yep .. Нет предупреждений: /
добавлено автор Nina, источник

1 ответы

The last time I had a similar issue, a normal clean wasn't enough, as it left some derived data. In Xcode, select the Product menu and hold down the option key to reveal "Clean Build Folder...", or even better, close Xcode and delete /Users//Library/Developer/Xcode/DerivedData/ entirely.

0
добавлено
Команда + Alt + Shift + k очищает весь проект (так же, как вы упомянули). Я перезапустил свою машину в другой раз, и теперь я могу запустить ее с помощью Xcode 4.2 .. Все еще борюсь с Xcode 4.5 :(
добавлено автор Nina, источник