Создание файла gtkbuilder с gtk 3 с использованием python

В настоящее время я следую этому учебнику. Когда я запускаю соответствующий файл python, я получаю ту же проблему, что здесь (хотя я использую python, а не Vala).

Поэтому, видимо, я должен сказать python использовать gtk3, но как это сделать?

Я использую Ubuntu 12.04, python2.7, glade3.14.

1
добавлено отредактировано
Просмотры: 2
nl ja de

2 ответы

Это странно. Вы можете использовать GtkHBox или GtkVBox в качестве обходного пути. Тем не менее, эти два устарели недавно (в GTK 3.2), в пользу GtkGrid . Кроме того, вы можете обратиться к официальному Python GTK 3 учебник .

2
добавлено
Спасибо, ты поставил меня в правильное направление.
добавлено автор marktani, источник

Хотя я не нашел причину проблемы, я заставил ее работать, просто скопировав содержимое my.glade в another.glade, открыв на поляне, сохранил его и запустил скрипт. Я, наверное, допустил ошибку, которую я больше не могу воспроизвести, ну ладно.

Спасибо, хотя для обеспечения свободы, поскольку в опубликованном учебном пособии дается более полное представление о «стороне gtk +» проблемы, пока я сосредоточен только на поляне.

0
добавлено