iOS 5 iPhone Simulator

Мое приложение терпит крах на iOS 5, но я понятия не имею, что вызывает это. Все мои устройства обновляются к iOS 6 (я не могу понизить), и проблема находится на iPad 1, который не может быть обновлен к iOS 6.

Я задаюсь вопросом, есть ли способ, которым я могу использовать симулятор с iOS 5, чтобы проверить/отладить это? Действительно ли это возможно? Спасибо

1
nl ja de
@KevinDTimm Вы действительно ожидаете, что инди dev будет владеть 10 * 3 = 30 устройств?!?! (10 устройств с 3 версиями iOS начиная с вас can' t снижение)... и that' s по крайней мере 30 устройств.
добавлено автор 0xSina, источник
@rmaddy, не уверенный, если я понимаю. Я не могу понизить до более низкой версии iOS, как только я модернизирую. There' s по крайней мере 10 устройств и поддержка iOS 4.0 +.
добавлено автор 0xSina, источник
@rmaddy я знаю меня don' t нужно каждое устройство, чтобы проверить данную версию iOS - Но that' s, что KevinDTimm, предложенный, таким образом, я сказал ему that' s не практичный как you' ll нужно много устройств.
добавлено автор 0xSina, источник
Можно отладить устройство, в то время как включено отладчик XCode.
добавлено автор Hot Licks, источник
@rdurand И большинство людей can' t предоставляют огромное количество однозвездочных обзоров потому что они didn' t потрудились проверять свое приложение через все версии iOS, которую их приложение утверждает, что поддержало. Кевин просто делает правильное замечание о тестировании.
добавлено автор rmaddy, источник
@0xSina, Почему 30 устройств? Вы don' t нужна каждая версия на каждом устройстве на iOS. That' s глупый. Одного устройства за версию iOS достаточно, чтобы, по крайней мере, проверить, что вы - not' t использование более новой ПЧЕЛЫ на более старых версиях.
добавлено автор rmaddy, источник
@0xSina, При использовании Xcode 4.5 тогда вы только, может поддержать 4.3 или позже. Лично, я оставил 4.x только что. There' s так мало пункта, чтобы поддерживать, что далеко назад больше. И снова, вы don' t нужно каждое устройство, чтобы проверить данную версию iOS.
добавлено автор rmaddy, источник
Согласованный @rdurand, проверяя с более старыми симуляторами не лучше, чем никакое тестирование, пока тестер полностью осведомлен об ограничении симулятора.
добавлено автор rmaddy, источник
@rmaddy: Я соглашаюсь, я сам проверяю на каждом версии, я требую своих поддержек приложений на симуляторе или с бета-тестерами. Обратите внимание, что мой комментарий был значительным отрицанием. Я полностью соглашаюсь с точками зрения, указанными здесь. Я полагаю, что работа над симулятором для предыдущих версий iOS еще лучше чем ничего:)
добавлено автор rdurand, источник
@rmaddy: +1 для понижения 4.x.. Мне нравится использовать раскадровки, и это были бы сумасшедшие перья обработки & раскадровки и поддержание обоих.. у iOS есть большое принятие обновления пользователями, таким образом, iOS 5 + не так строга. Кроме того, я can' t соглашаются больше на различных поведениях между симулятором и устройством.
добавлено автор rdurand, источник
@KevinDTimm: не все могут предоставить наличие многих устройств со многими предыдущими версиями ОС и вами don' t хотят ограничить вашу пользовательскую цель просто по этой причине:)
добавлено автор rdurand, источник
@HotLicks: Он doesn' t владеют устройством с iOS 5
добавлено автор rdurand, источник
К сожалению, that' s стоимость ведения бизнеса - если вы говорите, это работает над устройством система X/operating Y, вы лучше быть в состоянии проверить его. Иначе, как сказано выше, вы получаете полную лодку 1 звездного обзора - который является более дорогим?
добавлено автор KevinDTimm, источник
@rdurand - расчетный риск, there' s цена, чтобы заплатить за эту экономику
добавлено автор KevinDTimm, источник
Это указывает на опасности развития для устройств вы don' t собственный - разработчик протеста
добавлено автор KevinDTimm, источник
катастрофа может произойти из-за "выбора" Авторасположения Использования на xib между прочим, можно хотеть заботиться о нем
добавлено автор user1111278, источник

1 ответы

Да вы, вероятно, можете (это быть возможным, что проблема только появляется на устройстве, не в симуляторе).

To download the iOS 5 simulator (iPhone & iPad), go to the settings in Xcode, in the "Downloads" section, and install iOS 5.0 and/or iOS 5.1 simulators. Then select the appropriate simulator on the upper left corner of the main window of Xcode before running your app. Also make sure the deployment target of your app is set to iOS 5.0 (first item on the list of the left panel in the main window, select your target and in the "Summary" tab, set your deployment target).

7
добавлено
Спасибо, делая это прямо сейчас. Надо надеяться, я мог разбить эту ошибку.
добавлено автор 0xSina, источник
Если цель развертывания 5.1 тогда приложение wouldn' t устанавливают на устройстве с 5.0.
добавлено автор rmaddy, источник
Так как приложение терпит крах на устройстве с iOS 5, app' s цель развертывания должен уже быть 5.x (или 4.3).
добавлено автор rmaddy, источник
@0xSina: И если вам удается получить больше деталей о катастрофе, don' t смущаются открывать новый поток, чтобы получить помощь!
добавлено автор rdurand, источник
Я знаю, но он может также хотеть проверить/отладить на iOS 5.0
добавлено автор rdurand, источник
Что, если цель развертывания - iOS 5.1 и он пытается управлять им под iOS 5.0?
добавлено автор rdurand, источник
Mobile Dev Jobs — вакансии и аналитика
Mobile Dev Jobs — вакансии и аналитика
6 187 участник(ов)

Публикуем вакансии и запросы на поиск работы по направлению iOS, Android, Xamarin и т.д. ВАЖНО: Правила публикации и правила канала: Ссылка – https://telegra.ph/Pravila-oformleniya-vakansij-i-rezyume-11-09-2

iOS Developers — русскоговорящее сообщество
iOS Developers — русскоговорящее сообщество
2 400 участник(ов)

Общаемся на темы, посвященным iOS-разработке, Swift, Objective-C, SDK, Rx, Cocoa и т.д.