Сообщение об ошибке, относящееся к limma, используемому с использованием R 2.15.2

Недавно я обновил R, а код, который я написал с использованием пакета limma, до сих пор возвращает ошибку.

Код был

classes = c(rep('Phenotype1',), rep('Phenotype 2',))
classes= as.factor(classes)
design=model.matrix(~classes-1)
colnames(design)=levels(classes) 
fit1= lmFit(exset, design)
cm=makeContrasts(Phenotype 1 - Phenotype 2, levels=design)
fit2= contrasts.fit(fit1,cm) 
fit3= eBayes(fit2)

С новой версией R следующая команда

fit2= contrasts.fit(fit1,cm)

возвращает это сообщение об ошибке ...

Error in .Call("La_chol", as.matrix(x), PACKAGE = "base") : 
Incorrect number of arguments (1), expecting 2 for 'La_chol'
1
nl ja de

1 ответы

limma - это пакет из проекта BioConductor, и каждая версия R имеет связанную версию BioConductor. Если вы обновили R без обновления пакетов BioConductor (включая limma), могут возникнуть некоторые несовместимости. Вы уверены, что используете последнюю версию limma и BioConductor?

1
добавлено