Rails испортил не могу найти драгоценные камни

Я не знаю, что происходит с моей установкой рубинов/рельсов под OSX Mountain Lion.

Я начинаю с приложения черных рельсов, запускаю пакет и перечисляя установленные пакеты с bundle show . Я получаю это:

[..]
* sqlite3 (1.3.7)
* thor (0.17.0)
* tilt (1.3.3)
* treetop (1.4.12)
[..]

Как только я запускаю rake db: migrate, я получаю следующую ошибку:

Could not find thor-0.17.0 in any of the sources
Run `bundle install` to install missing gems.

Но, как показано, устанавливается грудь-0,17. Если я его заставлю:

sudo gem install --version 0.17 thor 
Successfully installed thor-0.17.0
1 gem installed
Installing ri documentation for thor-0.17.0...
Installing RDoc documentation for thor-0.17.0...

И снова запустите миграцию, у меня все еще есть ошибки зависимостей (в данном случае «Не удалось найти formtastic-2.2.1 в любом из источников») для драгоценных камней, которые, как говорится, уже установлены. Любая помощь? благодаря

<Сильный> ИЗМЕНИТЬ

0
nl ja de
Эй, можете ли вы вставить весь Gemfile и Gemfile.lock в gist/pastebin?
добавлено автор Intrepidd, источник
может вывести сообщение o/p из следующих команд: ruby ​​-v, и если вы используете rvm, тогда rvm rubies, похоже, что рубиновый рассогласование между рубином по умолчанию, который поставляется с установленным mac и ruby ​​позже.
добавлено автор Bijendra, источник
сделанный! Спасибо за ваш интерес
добавлено автор pistacchio, источник
это дает ошибку при установке sqlite3 /Library/Ruby/Gems/1.8/gems/sqlite3-1.3.7/lib/sqlite3/sqlite‌ 3_native.bundle: [BUG] Ошибка сегментации ruby ​​1.9.3p327 (ревизия 2012-11-10 37606) [x86_64-darwin12.2.0]
добавлено автор pistacchio, источник
Что произойдет, если вы запустите bundle exec rake db: migrate ?
добавлено автор Sam Peacey, источник

1 ответы

Поэтому после использования Gemfile я получил следующую ошибку:

Bundler could not find compatible versions for gem "railties": In Gemfile: rails (= 3.2.8) ruby depends on railties (= 3.2.8) ruby

sass-rails (~> 3.2.3) ruby depends on
  railties (3.2.11)

Bundler could not find compatible versions for gem "actionpack": In snapshot (Gemfile.lock): actionpack (3.2.11)

In Gemfile: meta_search (>= 1.1.0.pre) ruby depends on actionpack (~> 3.1.0.alpha) ruby

Running bundle update will rebuild your snapshot from scratch, using only the gems in your Gemfile, which may resolve the conflict.

Использование рельсов с версией 3.2.11 фиксировало комплект.

Rails 3.2.11 исправляет огромную угрозу безопасности, так что обновляйте!

0
добавлено
если вы удалите Gemfile.lock, что произойдет?
добавлено автор Intrepidd, источник
Не могу помочь вам, к сожалению, работает со мной: /
добавлено автор Intrepidd, источник
Я обновил версию до 3.2.11. вот новый Gemfile и Gemfile.lock: pastebin.com/MLqWnbjh pastebin.com/8KHAr5Lb Я все равно получаю ту же ошибку:« Не удалось найти bourbon-3.0.1 в любом из источников », но show bundle show что он установлен
добавлено автор pistacchio, источник
не изменяется: /
добавлено автор pistacchio, источник
pro.ruby
pro.ruby
1 181 участник(ов)

Язык программирования Ruby Additional docs: https://rubyreferences.github.io/rubyref/ Invite: https://telegram.me/joinchat/Be4rsT2NuB3CyJaF26j1kA Кто хочет компилировать: @crystal_ru (его синтаксис основан на Ruby) Участник @proDOT

Ruby, Rails, Hanami | dry-rb
Ruby, Rails, Hanami | dry-rb
1 180 участник(ов)

https://telegram.me/rubyjob - Ruby Job По вопросам - @eugene_shved

Ruby School .us
Ruby School .us
1 045 участник(ов)

Чат-болталка для учеников руби-школы и не только. Правила: https://telegra.ph/Pravila-chata-Rubi-shkoly-03-13

Random Ruby Chat
Random Ruby Chat
589 участник(ов)

Правила публикации вакансий: https://t.me/codenamecrud/60865

Rubyata
Rubyata
333 участник(ов)

Коммюнити Ruby и Ruby On Rails Флуд не приветствуются. Вакансии можно публиковать только и ТОЛЬКО по пятницам с хештегом #вакансия.

Ruby Talks
Ruby Talks
236 участник(ов)

Национальная Флеймотека

RubyRush
RubyRush
189 участник(ов)

rubyrush.ru программирование для самых новичков

Rails Chat
Rails Chat
87 участник(ов)

You are welcome to discuss Ruby On Rails development process and other stuff