Simperium получил неверное изменение

Я развиваю интеграцию с Simperium, интеграция завершена и на какое-то время работает на тестовых машинах, я начинаю получать эту ошибку на одном из устройств и постоянно повторяю любые идеи?

MeetingPad [891: 1103] Ошибка Simperium (ActionLinks82), получила неверное изменение для (a18852011efe4964a6fdeb1853c790f3) 2013-02-07 10: 07: 05: 277 MeetingPad [891: 1103] Клиент Simperium ios-7f43b434754d882923e966df5d885755 получил изменение (ActionLinks82) ios-4176925448fa8ae0a2f1d0937627aa6b: {     ccids = (         3f3b4550b23147d49e194038feea09a6     );     clientid = "ios-4176925448fa8ae0a2f1d0937627aa6b";     cv = 5112df4b37a401031dcc5be1;     ev = 2;     id = 9ca0b7ad04314ab9888d75691be784b5;     o = "-"; }

Если это произошло в учетной записи пользователя, каково было бы руководство?

0
nl ja de

1 ответы

Необходимо проверить, что вы используете последнюю версию кода. Недавно репозиторий открылся в GitHub . Раньше была ошибка, связанная с значениями nil, которые могли бы привести к тому, что недопустимый diff появлялся в вашем потоке изменений, но теперь он должен быть исправлен.

Предполагая, что вы используете последний код, повторяется ли постоянная ошибка для одного и того же значения «id» или существуют разные значения?

Если посмотреть на код Simperium, где возникает эта ошибка, возможно, он может быть отображен, если вы удалили объект локально и удаленно примерно в одно и то же время. В вашем приложении может ActionLinks соответствовать этому шаблону, т. Е. Вы создаете и удаляете многие из них на нескольких клиентах?

Если это действительно причина, тогда ошибка безобидная, и мы должны исправить код. Дайте мне знать, что вы открываете.

0
добавлено
Хорошо, дайте мне знать, если вы узнаете что-нибудь еще. Если вы все еще видите, что это происходит на устройствах, это поможет, если вы можете связаться с нами и дать нам более подробную информацию о вашем случае использования, поэтому мы можем подумать об этом еще немного.
добавлено автор mikejohnstn, источник
Привет Майк, я играл с этой ошибкой и думал, что дам вам несколько отзывов. Я использовал последнюю версию SDK и по-прежнему имел ту же ошибку. Я думаю, что это может быть связано с тестированием на симуляторе XCode и заменой между различными симуляторами (т. Е. С 5,1 до 6,0 до 6,1)
добавлено автор SM-UK, источник