Медленная загрузка после чистой установки Natty

Время поднялось с 20-25 секунд в Мееркат до 35 секунд в Натти. Я не знаю, является ли это ureadahead , но сделал ошибку в стартовой панели. Я попробовал Fedora незадолго до установки Natty. Они используют systemd вместо upstart и не имеют этой медленной загрузки.

В dmesg этот прыжок появляется:

[    3.087606] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[   15.292831] <30>udev[308]: starting version 167

Как могло случиться, что загрузка стала намного хуже? У меня также есть «черный экран» намного дольше, пока Плимутский всплеск начинается в Натти, а затем в Мееркате. Может быть, это знаменитая регрессия ядра?

11
nl ja de
У меня есть аналогичный журнал dmesg: [3.413050] EXT3-fs (sda6): смонтированная файловая система с упорядоченным режимом данных и [17.810635] Добавление замены 1998844k на/dev/sda5. Очередность: -1 экстентов: 1 по: 1998844k . Вы пришли дальше? У вас есть ссылка на отчет об ошибке?
добавлено автор Geoffrey Irving, источник
Эта страница от ubuntuforums.org исправила мою аналогичную проблему: ubuntuforums.org/showpost.php?p = 11388915 & postcount = 18
добавлено автор CoolHandLouis, источник
Внимательно .., когда вы используете EXT3, i EXT4 и я видел других с BTRFS. Это не файловая система.
добавлено автор Sandwich, источник
+1 У меня такая же проблема, и я также видел ее в выпуске dmesg других людей. Что он делает между секундами 3 и 20 ?: [3.106155] EXT3-fs (sda2): смонтированная файловая система с упорядоченным режимом данных [20.726183] Добавление замены 10239996k на/dev/sda3. Очередность: -1 экстентов: 1 по: 10239996k [20.784551] udev [301]: стартовая версия 167
добавлено автор wan, источник

4 ответы

Я установил ACPI = off в grub ... он работал :)

Он загружается примерно через 30 секунд (до этого 2-3 минуты).

2
добавлено
Попробуй это сделать. Я думаю, что это решение для другого регресса, чем у меня. Мое время ~ 20 сек.
добавлено автор Sandwich, источник

В файле /lib/udev/rules.d/60-persistent-storage.rules прокомментируйте это правило:

# ATA/ATAPI devices (SPC-3 or later) using the "scsi" subsystem
KERNEL=="sd*[!0-9]|sr*", ENV{ID_SERIAL}!="?*", \ SUBSYSTEMS=="scsi", ATTRS{type}=="5", ATTRS{scsi_level}"[6-9]*", \ IMPORT{program}="ata_id --export $tempnode"

Затем выполните команду root:

update-initramfs -u

Через http://kubuntuforums.net/forums/index.php?topic=3116527.0

1
добавлено
Хотя у меня есть дерьмовый DVDRW, это не сработало для меня. Спасибо за предложение. ;)
добавлено автор Sandwich, источник

Я бы посоветовал:

  1. Установите пакет cryptsetup . Это не наносит вреда вашей системе, но фиксирует длинный «черный экран» перед Плимутом.
  2. Удалите и установите пакет ureadahead . После этого выполните перезагрузку. Убедитесь, что файл/var/lib/ureadahead/pack создается через 1-2 минуты после перезагрузки.
  3. Теперь перезагрузитесь с помощью таймера:)
1
добавлено
Пробовал, но не решил мою проблему. Спасибо за предложение.
добавлено автор Sandwich, источник

У меня была странно медленная загрузка моего недавно установленного 11.04 (около минуты на совершенно новом компьютере). Затем я поменял SATA-порт на своем DVD-диске с порта 6 Гбит/с на порт 3Gb/s. Это изменение улучшило время загрузки до 20 секунд. Я не уверен, почему это сработало, но, безусловно, стоит попробовать, если ваш DVD-привод подключен к порту SATA 6 Гбит/с.

0
добавлено
Моя материнская плата старая, поэтому, скорее всего, это не для меня. Но спасибо за предложение. Бьюсь об заклад, кто-то другой может столкнуться с этой проблемой и ей поможет.
добавлено автор Sandwich, источник